Baud rate spontaneously changed

LK/ELK/VK/PK/OK/MX/GLK/EGLK/GVK/GLT Series

Moderators: Henry, Mods

Post Reply
tompuetzauthor
LCD?
Posts: 1
Joined: Sun Dec 16, 2018 8:28 am

Baud rate spontaneously changed

Post by tompuetzauthor » Sun Dec 16, 2018 9:37 am

Display LK202-25 Using TTL Connected to a Parallax BS2 microcontroller - baud rate set to 2400
After about four hours of operation the LK202-25 displayed random graphics and characters when the BS to sent text.
The Custom startup screen displayed correctly, but after the programmed pause the first menu sent to the LK202-25 displayed the random characters.

The problem [ re-occurred ] after
My fix : I disconnected the LK202-25 from the microcontroller and reset the baud rate to 19200 (connected jumper, powered up, powered off, remove jumper). Then I connected it to my computer running the "Display Tuner" to reset the LK202-25 baud rate to 2400.

When I reconnected the the microcontroller everything worked fine for about twenty-four hours of operation.

And then . . . . . . The problem [ re-occurred ]. Has this happened to anyone before ?

I have assembled more than twenty-five of these devices with microcontroller & LK202-25 pairing. They have all operated without problems.
Some for at least a year.

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 224
Joined: Thu Sep 24, 2015 9:38 am

Re: Baud rate spontaneously changed

Post by Daniel Divino » Mon Dec 17, 2018 12:25 pm

Hi Tom,

I understand your LK202-25 display is seemingly changing its baud rate after a few hours of operation.

Is there any way for you to log the values that are being sent to the display? The display itself won't change its baud rate out of the blue unless it receives a command from its host or if it were booted in manual override mode.

Also, once the LK202-25 stops responding properly, I see that you put it in manual override mode and connect it to Display Tuner to reset it back to 2400 baud. If, during your testing, the display seems to change baud rates again during operation, could you try connecting it to Display Tuner and communicating at 2400 baud (without booting it in manual override mode)? This would help verify whether or not the baud rate had been changed and saved on the display.

Cheers,

Daniel
Daniel Divino
Technical Support
Matrix Orbital

Daniel Divino
Matrix Orbital
Matrix Orbital
Posts: 224
Joined: Thu Sep 24, 2015 9:38 am

Re: Baud rate spontaneously changed

Post by Daniel Divino » Thu Dec 20, 2018 4:08 pm

After talking to Tom through email, we were able to determine that the spontaneously changing baud rate was due to a malfunctioning microcontroller.

Cheers,
Daniel
Daniel Divino
Technical Support
Matrix Orbital

Post Reply

Who is online

Users browsing this forum: No registered users and 17 guests